Clear Out Default Webmail Client

How do I clear out the selected default webmail client (cPanel on friday) so that instead of Horde, Roundcube, or Crossbox automatically loading when you click on “mail” that it gives you open to select a default webmail client again?

If your default is anything other than Crossbox, there’s a dropdown box at the top right where you can change the default (it’s the star icon by the webmail name). If your default is Crossbox, it’s a bit more complex:

Is there a way to do this for all users without having to individually log into each account? Or in cases where roundcube is blocked on the network so that when trying to open webmail it directly goes to roundcube and one does not have the opportunity to access the drop down box at the top right?

Arg. I can’t reply to your reply.

Each email account has it’s own default.

Right. But is there a way to “reset” for all users? I was search the internet for answers and there was some hint that a file could be deleted or modified, however, I wasn’t able to get the ‘file manager’ (cpanel -> domains -> click on House under document root) to load anything; I just get a "moving circle with “Fetching directory contents”. Maybe webdav (guessing) is blocked by network-appliance(s).

If port 2096 is blocked and you’re not using a custom webmail hostname (ex. webmail.yourdomain.tld) you shouldn’t have the opportunity to experience the immediate redirect to default at all anyway, so it shouldn’t make any difference unless I’m not understanding that properly. Regardless if you’ve loaded the cPanel-attached roundcube instance in browser you should have that menu at the top, it stays after the redirect.

Port 2096 is block but there is also Content and URL blocking, such that it senses Roundcube and block the site (webmail.<domain.tld>. I am not using port 2096, but rather from cpanel.<domain.tld> -> Email Accounts -> Click Check Mail and cpanel spawns a new window with webmail.<domain.tld>. The network-appliance(s) blocks the contents (not the window) of the new window. The window opens but the (webmail) content has been replaced with a message that roundcube is block and there are no drop downs anything since it’s from the network-appliance with the url of webmail.<domain.tld>.

So. I was just looking for a way to clear the default without needing access to webmail.<domain.tld> first.

I totally understand and I wasn’t expecting you manually do something. I was looking for something that I could do manually via one procedure rather than go through and manually set it for each email account that had already selected a default webmail client. And even then if I manually set a webmail client, I cannot set it to the system default so that the cpanel asks you which web mail client to use at time of use. I can only set to use one of three clients.

So, currently, the only way that I can think of setting it back to the cpanel default is go delete each user account and recreate it. Unless there is an option that I missed. Did I miss that option?

Not from user side at least. I generally shy away from manual workarounds as that tends to be how I get myself into a 3 hour fix for something that should’ve just worked.

Each email account has it’s own default.

If port 2096 is blocked and you’re not using a custom webmail hostname (ex. webmail.yourdomain.tld) you shouldn’t have the opportunity to experience the immediate redirect to default at all anyway, so it shouldn’t make any difference unless I’m not understanding that properly. Regardless if you’ve loaded the cPanel-attached roundcube instance in browser you should have that menu at the top, it stays after the redirect.

I suppose that’s an accurate assessment.