"smtp; 550 authentication required"

Help please… I just created a new email account ‘hello@{censored} [dot] me’ to use with WP Mail SMTP plugin on my site. I managed to configure the plugin and send a test email (using SSL with my mxroute.net server and port 465)

Test email arrived fine at: ryan [@] {censored} [dot] com

BUT whenever I try sending a reply from my mail client (Airmail 4 Pro) or via webmail, I get a rejection:

Delivery to the following recipient failed permanently:
[hello [@] ryansoperpowell [dot] me](mailto:hello [@] {censored} [dot] me)

Technical details of permanent failure:

550 authentication required

Reporting-MTA: dns; dal1relay254.mxroute [dot] com
X-ZoneMTA-Queue-ID: 173e27c9352000825f
X-ZoneMTA-Sender: rfc822; [ryan [@] {censored} [dot] com](mailto:ryan [@] {censored} [dot] com)
Arrival-Date: Wed, 12 Aug 2020 11:44:41 +0000

Final-Recipient: rfc822; [hello [@] {censored} [dot] me](mailto:hello [@] {censored} [dot] me)
Action: failed
Status: 5.0.0
Remote-MTA: dns; echo [dot] mxrouting [dot] net
Diagnostic-Code: smtp; 550 authentication required

How do I resolve this please? Also, all email accounts listed are being hosted on mxroute.

Thanks

It looks like this email went a remote path between two domains that exist on the server. Let me explain:

Let’s call the sender domain1.com, and the recipient domain2.com. Both domain1.com and domain2.com exist on the Echo server and are listed on that server, both domains have been added in DirectAdmin on that server. So when an email came in from a remote server (even though that server was one of our relays) claiming to be from domain1.com, exim said “I manage domain1.com and this sender wasn’t SMTP authenticated. This is clearly someone spoofing domain1.com.”

I don’t know how your email from the Echo server went out remotely instead of delivering locally on the Echo server, unless you hadn’t yet added domain2.com to DirectAdmin until immediately after you sent the email (or perhaps exim hadn’t refreshed yet?). This email should have failed because of it’s path, but it shouldn’t have taken that path, and I can find no evidence that it would take that path again right now.

To summarize:

Basically when you’re delivering email from one of your domains to another, both under the same account, the delivery should go like this:

sender (echo) -> recipient (echo)

But when you’re sending to someone who isn’t hosted on the same server, and the path your email took despite being hosted on the same server, was more like this:

sender (echo) -> filter003/004 -> dal/charlotte relay -> recipient (echo)

So at the time it was sent, Echo did not recognize that it was the email host for the recipient.

@Jarland - super grateful for the explanation SO are you in essence stating that:

I’ve since sent a test message (actually using the sign-up form on the foot of ryansoperpowell [dot] me website entering an old hotmail address I use… I received notifications as expected at the form-submission destination email address and a copy of the submitted form at the hotmail address…

HOWEVER, when I hit reply in Hotmail to reply to hello@ - I again received this error message.

I thought from your suggestion that you were guiding me to avoid sending back/forth between accounts hosted on echo. There’s not been any issue with any of the dozen or so accounts I’ve set up until today.

Attached, the first 47 lines of the diagnostic report
Screenshot 2020-08-12 at 20.32.52

I see a different reason now @RyanSP . I didn’t notice it earlier as it seems DirectAdmin changed how this function works, and so the usual indicators on the backend were not there. What had happened was that in DirectAdmin that domain was configured to be hosted externally. If you click a domain in the dropdown at the top and then click on “Email Routing” under E-mail Manager (you should select the domain first, the page doesn’t always refresh when changing the domain), there’s a checkbox that says “Use this server to handle my e-mails.” That had been unchecked. I’ve checked it for that .me domain now.

“Use this server to handle my e-mails.”

Thank you for this. In my case the option was under “Email Manager” -> “MX Records”.

Here’s a screenshot for any future viewers:

image

Woohoo!

Thanks as always @Jarland - that’s what comes of not living and breathing this config stuff every day… been about six weeks since I activated my account and spent 2-3 days porting accounts across to MXroute - so I’d forgotten that all-important tick box.

Appreciate your help.