Roundcube Forward/Redirect Inconsistency

I’m having trouble getting RoundCube to consistency forward a copy of emails to recipients. Sometimes the rule just doesn’t work at all. I can’t find a ryme or reason.
This is for a small non profit and my end goal is to get a copy of the message to about 10 people on the executive team when someone sends an email to a generic account like

I’ve got a rule setup so that any message less the 5Gb forwards to a couple email addresses. I’ve sent probably 5 hours trying to get it stable. I’ve tried every which way I can think of:
There’s only 1 rule.
The rule and rule category are enabled.
I’ve tried scope “All Messages” and some scopes with filters (Like Below 5Gb)
I’ve tried 1 email recipient, and I’ve tried up to 10.
I’ve tried “Sending Copy” and “Redirect”.

Sometimes it works and then it just quits.
I’m pretty sure it’s not a filter issue as sometimes the rule just doesn’t run. I’ve set the rule to also move the message or mark it read ect ect to see if the rule runs and it doesn’t even do that. So my assumption would be it’s not a spam filter that’s actually blocking the messages and it’s a problem with Roundcube. If it makes a difference these are going outbound to different domains of the teams private accounts, not internally.

Any help would be apricated. On Echo server if it makes a difference.

Yes, it makes a difference. The original sending domain matters as well.

Some domains enforce SPF/DMARC restrictions and some do not. For instance, you cannot forward an email sent from Facebook to an account on MXRoute on to a user on Gmail. Gmail will not accept the mail.

You should use Forwarders in DirectAdmin instead of redirect filters. Filters are too literal for most humans to understand, and they don’t use SRS.