Problem logging in to webmail on android

i’m trying to access my domain’s webmail on an android phone at ‘’ my DNS records are correct and i get the webmail login screen, but always get an authentication error after entering my username email address and password.

on a PC this works fine, so it’s not an incorrect password or email address. i’ve tried this on different android browsers, and with one of a number of different’s, without success.

any advice what i’m doing wrong i’d appreciate!

Welcome! So on this it’s important to not over think it, as that can be easy to do. It’s most likely going to be something simple. First, make sure your mobile view looks like this:

If it doesn’t, you may not be on our webmail. You might triple check DNS or wait longer for DNS caches to drop on your phone. Edit: It only looks like this if you are on a DirectAdmin server, not a cPanel server.

If it does, focus on the input. If we know the input fields accept the right values, and I can confirm that this is the same and working in either mobile or desktop view, then we have to assume the correct values are not being submitted. Now that doesn’t mean you’re physically making a mistake, it’s just the logical assumption. It could be an issue with a mobile keyboard (if using another, maybe try gboard for a solid default). It could be a password manager app filling it in behind you without you noticing.

I made an edit to my previous answer. It only looks like that screenshot for new customers on DirectAdmin servers, not for customers on cPanel servers. On cPanel servers I would still double check DNS, but note that the screenshot portion of my answer is irrelevant.

Hi Jarland,

sorry for the delay. i replied immediately, but in my mail client because i didn’t see the noreply address, and only just now got an Undeliverable notice.

This is what I get, no idea if it’s right. When trying to log in I get a red “the login is invalid” banner message after it tried to authenticate.

All my DNS is held by Cloudflare, but webmail is NOT proxied through their servers. For this and all my other webmail addresses I have a single CNAME record pointing at None of them work on Android, but do on desktop.

Does this give you any ideas?

I’ve got it, and it’s dumb. Android autocomplete adds a space after it fills in the email address. Webmail reads that as a character then returns an error for the email address (plus space) + password. Your reply DID help. Whether that’s something for you to look at or not, I wouldn’t know. Thanks again, Jarland! Close thread.

Thanks for that. That looks good. Your DNS is solid. That has me thinking back to what I said about input, which seems like a small possibility but ideas start to wear thin quickly with the variables.