Plesk and Contact forms through MXRoute

Hello!
I use Plesk in a vps environment (Lightsail) and since signing up with mxroute, I have uninstalled my mail server that comes along with Plesk for managing emails. Doing this stopped my WordPress sites from sending contact form messages. I’d also assume this disables the forget password functionality from working.

So I was looking around for help to get this working again and chanced upon this plesk help doc which says:

when the mail server is not installed or prohibited from sending outgoing mail, you face the problem: Plesk still needs to send notifications, and customers’ scripts may need to send emails. To solve this problem, Plesk can send outgoing mail through an arbitrary external SMTP server.

And recommends the following to be enabled, which I’ve already done.

My questions is, would enabling this option in Plesk, and
plesk email

setting up mxroute details for external SMTP server help the websites to start sending contact forms messages again?
plesk external smtp

Yes - you need to put in the SMTP settings corresponding to your MXRoute account. Based on the last screenshot you showed there are no login details provided so Plesk doesn’t know what SMTP server to use. This explains why you aren’t able to send any.

thanks for replying!

For the host name or IP, is that the value given in the mxroute control panel?
mxip

As for the username and password, should I be using the MXroute control panel login credentials? Or do I need to create a new login key to use with plesk?

plesk external smtp

mxroute loginkeys

Thanks for replying @gray, especially for trying to help me out when you’re not even a staff. Thanks to you too mate @Alento

Right, so I added a new domain (my plesk default server url which I use to log into plesk) and created a noreply email account.
plesk mx

after that added the noreply email account at plesk’s External SMTP Server Settings and enabled all the check boxes.

image

Now the question is, do I need to open up the port at my VPS too? because this is what I have in my lightsail port settings.

image

After reading through Lightsail’s guidelines on firewalls, they say

All internet traffic into and out of your Lightsail instance passes through its firewalls. An instance’s firewalls control the internet traffic that is allowed to flow into your instance. However, they don’t control the traffic that flows out of it—the firewalls allow all outbound traffic.

So, I didn’t open up port 25 because in my understanding, these notification emails are considered as outbound messages, is that correct or do I have to open up port 25 for the notification emails to flow?

I’m not familiar with lightsail as I don’t use it but based on the image you provided you shouldn’t need to as it would be an outbound connection.

You can always verify this by trying to send emails through plesk and seeing if it’s working.

Why have you set the port to port 25? Nowhere in any MXRoute documentation is there instructions to use port 25 for SMTP. You need to use port 465 as stated in the [Important Account Information] email.

IIRC Lightsail does not even allow one to use port 25. As for your firewall, port 465 needs to be open for OUTGOING connections. I do not know if that means you have to set anything or not as I do not use Lightsail.

Thanks for replying guys, I did open up port 465. I dont think the issue is to do with MXroute, as I can send and receive email with the noreply email account. So it’s plausible that the issue is with the server settings or something.

I’ve documented what I did in the Plesk forum too, here’s the link if you want to take a look.

Thanks anyway for taking time to help me out. If I find a solution, I’ll post it down here for others.

This will be whatever server you are on and should have been in your original account creation email. I.e arrow.mxrouting.net, lisa.mxrouting.net, etc. I’m not an employee just another user so I can’t provide this information to you and it’s dependent on what server you were provisioned on.

With regards to credentials - put in the username and password for whatever email account you are wanting to send email through. You can make one specifically for plesk if that’s easier for you to keep track off.

The control panel login isn’t an email account and is simply used to manage your domains/email accounts.

Login keys have absolutely nothing to do with what you are wanting to accomplish …

I am also seeing a gmail.com email address in one of your images - that does NOT look correct at all as it is in the same image as one would find in the Direct Admin control panel.

You need to create an email account and use those credentials as @gray has indicated.