Not receiving emails

Hi,
i can send but can not receive email.
i tried 2 options of txt:
“v=spf1 a mx ip4:185.165.242.234 ~all”
or
“v=spf1 include:mxroute.com -all”
But same issue
https://www.whatsmydns.net/#MX/vuahieusuat.vn not point to MXRoute (6 hours after set)
MX 01 MX 02
Please help

You need to create an MX record for lisa.mxrouting.net with priority 10 and lisa-relay.mxrouting.net with priority 20. It looks like you’ve created mostly everything besides that.

On a side note I’d also use the mxroute.com or mxlogin.com SPF record but I’m not totally sure if it makes a difference.

Thanks
But i need host info
please see image
need
Thanks

Thanks
i edited, please see and help
https://www.whatsmydns.net/#MX/www.vuahieusuat.vn
111 222
thanks

It’s all found in the Important Information e-mail received upon ordering (do check Junk folder if not found in inbox). Can also be found from the “Hello, Your Name” menu in the portal, under “Email History”.

Looks like there should be preference 10 and 20 for each MX record, screenshot confusing.
I suggest you reach out on chat.mxroute.com instead.
(And you are provisioned on the Lisa server?)

Thanks.
Well done after fix

Your MX records are correct now (assuming that you are on the Lisa server).

Your TXT record is not though. Try it again without the quotes. " Again it is important for you to discover how your DNS provider requires the records to be entered. The DNS system is showing the record with extraneous characters.


; <<>> DiG 9.9.5-3ubuntu0.17-Ubuntu <<>> vuahieusuat.vn TXT
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26894
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;vuahieusuat.vn.			IN	TXT

;; ANSWER SECTION:
vuahieusuat.vn.		14055	IN	TXT	"\226\128\156v=spf1 include:mxroute.com -all\226\128\157"

;; Query time: 35 msec
;; SERVER: 10.9.0.1#53(10.9.0.1)
;; WHEN: Tue Apr 21 12:39:25 CEST 2020
;; MSG SIZE  rcvd: 93

On another note, 2 of your 4 name servers are not responding. You may want to move your DNS to a more reliable provider.

@tisaigon

What you use as ‘host’ depends upon your DNS provider. Most providers you will leave that field blank, with some you will enter @. Check with your DNS provider to determine how they require the records to be entered.

Additionally, the TXT (SPF) record needs to be “v=spf1 include:mxroute.com -all” not what you have entered.

The SPF TXT record has not been corrected. @tisaigon

@Jarland i’ve already set like this…

2020-05-05_08-14-27

That domain currently has no MX records configured at the DNS host (digitalocean).