My web app doesn't send out an email with SMTP

Hello,

I am setting “password reset” page on my web app.
The browser responds status 200, but I can’t receive the email.

How can I fix and where should I get logs from?

Thanks,

You may want to enable debug logging in your interpreter (for example, in php.ini if PHP) and see if you can get more insight into what it’s actually doing.

Your username and password will be what you set up following these steps: https://mxroute.com/docs/add-new-email-account/

Sadly that isn’t anything useful.

Afraid not. We know our SMTP servers are up and running, so third party tests to determine if it is or isn’t won’t be much help. You’re going to have to dig into the debug logs for your interpreter (which appears to be PHP). You may need to reach out to your developer or system administrator at this stage, as it seems that you may not be aware of how to configure and work with PHP logging.

In your case that’ll be:

Host: blizzard.mxrouting.net
Port: 465 (with SSL)
Username: username@domain.tld (whatever you created in DirectAdmin under Email Accounts)
Password: What you set when creating the above

Alternate ports:
587 (STARTTLS)
25 (Non-SSL)
2525 (Non-SSL)

Thank you for your support.

Do you mean this?

172.19.0.1 - - [05/Oct/2020:06:46:15 +0000] “GET /passwd_forgot HTTP/1.1” 200 3892 “-” “Mozilla/5.0 (Linux; Android 6.0; Nexus 5 Build/MRA58N) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.121 Mobile Safari/537.36”
172.19.0.1 - - [05/Oct/2020:06:46:15 +0000] “GET /passwd_forgot.php HTTP/1.1” 200 889 “http://localhost:8100/passwd_forgot” “Mozilla/5.0 (Linux; Android 6.0; Nexus 5 Build/MRA58N) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.
4183.121 Mobile Safari/537.36”
172.19.0.1 - - [05/Oct/2020:06:46:15 +0000] “GET /sm/fce9748308f79c28aa5a62ea9d002732d8c4a1c8eaadedab834d5c92787c6fa3.map HTTP/1.1” 404 8814 “-” “Mozilla/5.0 (Linux; Android 6.0; Nexus 5 Build/MRA58N) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.121 Mobile Safari/537.36”
172.19.0.1 - - [05/Oct/2020:06:46:15 +0000] “GET /dmxConnect/api/Security/loggedin.php? HTTP/1.1” 200 467 “http://localhost:8100/passwd_forgot” “Mozilla/5.0 (Linux; Android 6.0; Nexus 5 Build/MRA58N) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.121 Mobile Safari/537.36”
172.19.0.1 - - [05/Oct/2020:06:41:27 +0000] “POST /dmxConnect/api/Passwords/request_new.php HTTP/1.1” 200 384 “http://localhost:8100/passwd_forgot” “Mozilla/5.0 (Linux; Android 6.0; Nexus 5 Build/MRA58N) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.121 Mobile Safari/537.36”
172.19.0.1 - - [05/Oct/2020:06:46:35 +0000] “POST /dmxConnect/api/Passwords/request_new.php HTTP/1.1” 200 384 “http://localhost:8100/passwd_forgot” “Mozilla/5.0 (Linux; Android 6.0; Nexus 5 Build/MRA58N) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.121 Mobile Safari/537.36”
172.19.0.1 - - [05/Oct/2020:06:46:39 +0000] “GET / HTTP/1.1” 200 3892 “http://localhost:8100/passwd_forgot” “Mozilla/5.0 (Linux; Android 6.0; Nexus 5 Build/MRA58N) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.121 Mobile Safari/537.36”
172.19.0.1 - - [05/Oct/2020:06:46:39 +0000] “GET /home.php HTTP/1.1” 200 2244 “http://localhost:8100/” “Mozilla/5.0 (Linux; Android 6.0; Nexus 5 Build/MRA58N) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.121 Mobile Safari/537.36”

Yeah that looks fine.

Yeah but I wouldn’t spend time there while your app isn’t even connecting to us to send the mail. https://mxroute.com/docs/dns-records/

Yeah if you don’t mind reading exim logs. In Email Accounts in DirectAdmin there’s an “in/out” next to each email account. That shows logs for in/out (depending on which one you click). I can already tell you that it’s empty though. I think once again you’ve run out of options other than to reach out to the developer of the app.

I checked the logs against the IP of your website’s server, which looks to be a DigitalOcean droplet. I found no logs, which either means I’m checking the wrong IP or your server isn’t even trying to connect to ours. Could be that DigitalOcean is blocking SMTP ports for your droplet, but a decent app should be erroring out if so. Looks even more like digging into the debug logs of your interpreter (which appears to be PHP) will be necessary. If uncertain how to do that, you may want to reach out to the developer of your application.

An alternate may be to reach out to @Alento who accepts jobs helping customers get set up.

Those are just web server logs, you’ll need to find out what your application is actually doing. If not via debug logs then perhaps an strace of the PHP process as it runs.

I think I’ve made a mistake for the configuration…
But I still don’t get some part…

When I set a mailer on the app, what is the password? I could not find it in the reg file. Is it what I set when I created an account?

I’m developing this web app by myself btw.

JarlandOwner

1h

It worked! thank you so much!

However, I haven’t received a test email yet.

Am I missing this configuration? how should I set this?

I changed the configuration. and I got this error this time.

172.19.0.1 - - [ 06/Oct/2020:04:10:04 +0000 ] “POST /dmxConnect/api/Passwords/request_new.php HTTP/1.1” 500 1553 “http://localhost:8100/passwd_forgot” "Mozilla/5.0 (Linux; Android 6.0; Nexus 5 Build/MRA58N) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.121 Mobile Safari/537.36"

Then saying that it worked may be premature, no?

when I did https://testconnectivity.microsoft.com/tests/O365OutboundSmtp/input

I got this error.

スクリーンショット 2020-10-06 14.11.24

does this help?

I have no logs of any outbound mail from your domain on the Blizzard server, except for the one you sent on September 28 via webmail (which failed because at the time you had no MX records set). I’m going to stand by the idea that your application isn’t trying to connect to our server.

スクリーンショット 2020-10-07 10.41.56

Now I got this. is this OK?

and how about SPF RECORED? do I need to configure it? if so, how?

@Jarland
thank you so much for spending your time.

I think I could configure all required things finally. (I missed many things)