How to set things up

I bought a domain at a host I use expressly to use for handling family personal email. I then bought a year here and created a couple of email accounts.
I did some setup at NFSN. Following instruction from you - MXRoute - I added resource records a day or so ago as follows:
MX - 10 longhorn.mxrouting.net.horselovers.party.
MX - |20 longhorn-relay.mxrouting.net.horselovers.party.
TXT - |“v=spf1 include:mxlogin.com -all”
CName - longhorn.mxrouting.net.horselovers.party.
CNAME - longhorn.mxrouting.net.horselovers.party.

As things stand now I can successfully go into Webmail and send from these email accounts to email addresses I control. But when I reply to them I get undeliverable email messages back that say-

Blockquote
Unfortunately, your mail was not delivered to the following address: xxxxx@horselovers.party: Sorry, I couldn’t find a mail exchanger or IP address. (#5.4.4)

I can successfully send emails to back and forth from and to the email accounts from within the webmail system

Can you point me towards how to get things working?

Thanks

Those records are incorrect. The records you have added are not as per the instructions that MXRoute provides.

When you enter the records put a . (period) at the end of the value such as:

longhorn.mxrouting.net.

This should fix your issue, and is a reason that MXRoute specifically states that knowledge of how to properly enter DNS records is required to use the service. There are literally 1000’s of potential DNS providers, some require the period that I mentioned, some do not. It is up to each user to be aware (or to be able to contact their DNS providers support) of how records must be entered. :slight_smile:

If this doesn’t solve things … let me know.

It is entered as

Do I need to edit it? Remove the period after party?

Thanks to the help of@Alento I was able to find the issues with how I had entered my resource records. After fixing them all - deleting the extra stuff after longhorn.mxrouting.net.`
with them shortened and that trailing period - everything began working.

I am now doing the SSL certificate setup and am getting an error message

Error: http://mail.horselovers.party/.well-known/acme-challenge/letsencrypt_1572998795 is not reachable. Aborting the script.
dig output for mail.horselovers.party:
longhorn.mxrouting.net.horselovers.party.
Please make sure /.well-known alias is setup in WWW server.

Any ideas on how to fix this one?

If the period was properly entered, your record would show

MX - 10 longhorn.mxrouting.net.

If you indeed entered a period, contact your DNS providers support.

It appears that the changes you made have not yet propogated to Let’s Encrypt’s DNS servers … they tend to be slow. Wait a bit (10-15 minutes) and try again.

I also see an issue with the SPF record that you entered. Your DNS provider added a set of quotes around the entry, so you need to remove the quotes. :frowning:

Cool
I removed the quotes. Will see how long for propagation.
I’m supposed to use the - Free & automatic certificate from Let’s Encrypt - option right?

That sounds correct … make sure that the primary domain unchecked. See near the end of this document for an example:

https://mxroutehelp.com/index.php/2019/08/25/custom-webmail-pop-imap-smtp-domain/

1 Like

Yes - I found that article and got it done.

I wanted to get back here and kinda summarize what I learned while it is fresh in my mind to help other Newbs that might be looking for this kind of info. Heck I might need to come back here for a refresher even.

For MX records with my registrar’s control panel the correct formatting was:
MX - 10 longhorn.mxrouting.net.
MX - |20 longhorn-relay.mxrouting.net.
TXT - v=spf1 include:mxlogin.com -all
CName - longhorn.mxrouting.net.
CNAME - longhorn.mxrouting.net.

Notes -
For MX & CNAME Records : It looked to me like the control panel was supplying the periods after .net. In fact when I did not manually enter the period it added a dot and then my domain name and that screwed things up. Manually enter the period

For TXT Record - the instruction letter says - “v=spf1 include:mxlogin.com -all” but including the quoptes is wrong. Enter it without the quotes -
v=spf1 include:mxlogin.com -all

When doing the SSL Certificate part - Choosing Free & automatic certificate from Let’s Encrypt- Don’t forget the part about unchecking some of the lines or you will get an error message. See instructions at the bottom of -
https://mxroutehelp.com/index.php/2019/08/25/custom-webmail-pop-imap-smtp-domain/

Looks like just SSL is left to go! :slight_smile: