How to Auto Delete Read Mail

What a Great Platform!

I am having email forwarded to GMAIL for aliasing on some accounts.

How would I auto delete the emails on the server since a forwarded copy will exist on GMAIL to conserve quota space please?

I could not find the option to deleted fetched/forwarded email

Thank You

Sorry that I am late to the party @Matrix.

I think that the solution you may want is to use Gmail’s ‘mail fetcher’.

This link from a random web host gives more detail.

https://www.doteasy.com/domain-email-and-website-hosting-articles/importing-your-domain-email-account-into-your-gmail-account

The easiest way is just to delete the email account and set up a forwarder. A forwarder with no matching email account will just forward and not store on the server. But if you want to store them on the server and just delete every now and then, I think that might have to be done with third party software (certainly it could be done over the IMAP protocol).

Hi Jarland,

When i tried to delete the email, the email gets forwarded to GMAil properly.

But when i try to send it from GMAIl as an Alias, this is what I get:

image

So I am assuming you need to have an existing account to be able to SEND as that account? It was not just for forwarding but to be able to send as the account as well.

Please confirm this is the case so I can look into third party software.

Thanks!

That’s actually a really bad thing to do. If one of the forwarded emails fail, I’ll have to disable your entire account while I manually undo that setting. It’s because if one email fails, then it bounces back, which forwards, which bounces, which forwards, which bounces, repeat about 30,000 times until the entire infrastructure is falling over on itself and I’m dealing with an emergency.

Forwarders are able to understand some of this context, where filters are merely dumb tools that have no idea of context and do literally all that they’re told to do.

Ah yeah. You would need it for the sending part. I’m not sure what the best option is at that stage. Maybe @Alento or @flips have an opinion.

Thanks for all the suggestions. One members of the Tech groups I am in sent me this link as a way of assisting.

It is redirecting proecess instead of forwarding. I replaced the email address with ALL Messages since the email alone did not work. But it seems to be doing the trick.

Redirect and not Forwarding.

Thanks for all the help!!

Glad you informed me. Straight from the developer :slight_smile:

Save me some headaches

Alternative 2

I have set forwarding as you suggested. And then Filter All Messages to be deleted :rofl:

This seems to be working.

Thank you for the quick replies and suggestions

You could use a different user in the same domain for SMTP authentication, so it will send as forwardeduser@domain.com, while authenticating as relayuser@domain.com.

Or, maybe better, don’t forward, but fetch to GMail. Use a real account, let GMail fetch using POP3. (Forwarding is not always working optimally, even though Google now handles DMARC better, I think.) :slight_smile:

Of all the solutions, this was exactly it.

I do not need to fetch, make filters, or do anything else.

GMAIL Fetch does all the work, keeps MXRoute clear and works with alias SEND AS

Thanks thanks!!!