Error 535 with SMTP Sending

I have recently set up a $10 reseller account to try this out. I love it! Great job!
I did end up cancelling though because I plan on either buying a $30 normal account, or the $99 lifetime, If I can get this to work.

-MY ISSUE-
I am trying to sent emails with smtp via both a hosted gitea, and ssmtp directly in linux.
In both cases, I get error 535, auth failure when trying to send.

-NOTES-
-I have successfully used Mailgun to do this with both services to send on port 587. smtp.mailgun.org:587 When I switch to using mail.oldmanz.com:587, I recieve the error.
-I have no issues receiving mail via mxroute in both the webmail portal, and in android gmail app.
-I am using the same username and password with webmail as the smtp services.
-I have tried ports 25, and 465 as well.

Any help in where to look would be greatly appreciated!
Thanks!
-Z

The 535 error is “Incorrect authentication data” in this context. This is one it’s important to not overthink, as it’s pretty simple. Our server isn’t getting the correct credentials from yours. Could be because of a typo, an error in the software causing it to selectively send wrong credentials to some servers and right ones to others (that’d be weird, but if it works with one and not the other, and isn’t a typo…), or mixed up SSL settings.

If using port 25, use non-SSL. If 465, use SSL. If 587, use STARTTLS.

The username/pass you use should also work here, and if it doesn’t then you should reset the password from DirectAdmin: https://lucy.mxrouting.net/webmail (this only relevant to you, other customers may be on other servers).

If all else fails, try a simpler password. Maybe Gitea has a flaw that doesn’t parse certain characters.

Well, I am both pro and con for Cloudflare DNS. It is solid, but it is also taking control of too much of the internet.
@Jarland has wholeheartedly recommended ClouDNS in the past, though I have never used them. I do trust his judgment however.

Mostly I either run my own DNS or trust my registrar and sometimes even host to handle it, but …

anyone BUT GoDaddy is my answer.

Thanks for the quick response!
As per another thread on here, I tried all of these solutions and more.
I have even turned off automatic and forced the Correct SSL Settings with each port.
The username/ pass work at the webmail portal, and I have tried everything from a simple password with no special characters to a pretty elaborate one. (Mailgun forces the use of a generated pw that is about 30 characters long with dashes, and it worked in both gitea and ssmtp)
Maybe there is some kind of hashing going on? I wouldn’t think ssmtp would do that though.
I will continue digging. Thanks for your help! You have seriously put together a great product.

@tzimmerman15243

I see that you are using GoDaddy for DNS … no comment.

Do an experiment. Rather than using the hostname mail.oldmanz.com use the actual server hostname lucy.mxrouting.net .

If that works, change your DNS provider. GoDaddy’s DNS is absolutely horrible. I have encountered this situation before, and eliminating the extra lookup actually worked. So, this may work for you … or it may not.

Thanks for the reply @Alento! I put this issue down for a few days and came back to it when I received your reply and behold, IT WORKS…
It can only be the dns updating at Go Daddy is incredibly slow. However in my testing, using lucy.mxroute.net also did not work, so I wrote it off as not a dns issue.

Thanks for your help both of you, and I suppose if anyone else is having this issue, give it about 3 days for Go Daddy.
Question @Alento, what dns provider would you recommend? I was considering hosting my own, but not for awhile yet.