Emails not working from hosting servers

Bit of a strange problem - can’t pinpoint the culprit.

I have been using MXroute account, haven’t changed any settings, nor passwords for months (strong passwords, lots of characters etc.).

Using Gmail mail client configured to send and receive email through my MXroute email works fine. So I suppose there’s nothing wrong with the MXroute service. However:

WordPress websites use Easy WP SMTP plugin for sending emails - configured to use MXroute SMTP. This doesn’t work!
Another plugin, “Newsletter”, used to send newsletters - is also configured to use MXroute SMTP. This plugin works and sends emails.
Tested these two on three websites, on two separate servers - with the same hosting provide though.
Hence - I suspected there must be something wrong with the Easy WP SMTP plugin.

However! :slight_smile:
On a third server, with a different hosting provider, I’m using another application - “Infinite WP”.
This application is also configured to send emails using MXroute.
And it doesn’t work!
If it weren’t for this - I would suspect the Easy WP SMTP plugin.
But because of this - I’m checking here with you. Two apps on different servers both started not working at the same time. That is why I think it could be possible there’s something wrong with MXroute.

Could you check? Or point me in the right direction?

Edit:
I did ask one hosting provider’s tech support - wrote practically what I wrote here - asking them to check just in case. Got this reply (no PHP error log on the server as I had checked):

Possible causes would be the remote server you are trying to connect with in blocked in the firewall or a PHP coding issue.

We did some recent software updates, which included PHP updates, so that could be related. Trying checking the error_log for any related PHP errors.

If you can provide the IP or IP’s it may be trying to connect to, we can check the firewall on that server.

Any chance that server is on HostWinds? I blocked their IPs recently to send a message, as they’ve gone out of their way to not receive abuse complaints and their servers are being used for a heavy spam campaign.

EDIT 2:
It’s Sunday, I’m not “loosing millions” - have a look at it when it’s convenient. :slight_smile:

Not Hostwinds - HostMantis and MyW.pt are the “affected” hosting providers.

Though HostMantis says it’s nothing related to their server. Asked MyW.pt to have a look as well, if they can figure something out - just to confirm it’s not on their end (though I did have server related problems that took some time figuring out they are server related - catch 22 - can’t say that’s the case here - don’t know).

So still suspecting:

  1. both the plugin and the application broken at the same time, as well as the new SMTP plugin tested - not very likely.
  2. MXroute related problem A bit less unlikely.
  3. Server related problem - most likely - but two different hosting servers are giving problems.

EDIT 1:

Installed a different SMTP plugin. “WordPress Mail SMTP”. This one too doesn’t work. Error it gives with a test email:
(and tested Easy WP SMTP on MyW.pt - doesn’t work there either)

Could not connect to the SMTP host.

This means your web server was unable to connect to friday.mxlogin.com.

Typically this error is returned for one of the following reasons:

-SMTP settings are incorrect (wrong port, security setting, incorrect host).
-Your web server is blocking the connection.
-Your SMTP host is rejecting the connection.

Recommended next steps:

  1. Triple check your SMTP settings including host address, email, and password, port, and security.
  2. Contact your web hosting provider and ask them to verify your server can connect to friday.mxlogin.com on port 465 using ssl encryption. Additionally, ask them if a firewall or security policy may be preventing the connection - many shared hosts block certain ports.
    Note: this is the most common cause of this issue.
  3. Contact your SMTP host to confirm you are using the correct username and password.
  4. Verify with your SMTP host that your account has permissions to send emails using outside connections.

I was able to send test email right now using EasyWP SMTP plugin on MyW’s DE server, using account on London server, setup to use mail.mydomain.tld (CNAME to London, with Lets Encrypt cert created in DA) port 465 SSL.
:thinking: :man_shrugging:

Thanks @flips

Noted everything I tried and tested so far, along with my setup (configuration) in a structured way and with all the details I could think of - in case it helps pinpoint the problem:

My web server at hostwinds is unmanaged and entirely under my control. Is there a way it can be unblocked so that I can access smtp to send mail through echo.mxrouting.net ?

Thanks for the feedback. :+1:

P.S.
The link should have skipped the redis problem part - going to the email problem directly (works that way for me when clicking). Off topic: redis object cache does improve website performance to a degree. And had no problems with it on MyW.pt servers for that matter.

In case it helps:
My MyW sites run on PHP 7.4, Wordpress 5.4.1, LiteSpeed Cache 3.2, Easy WP SMTP 1.3.9.3
I don’t use Redis (not sure if/what I’d benefit from it, it’s on my “read more about” list).

Works (for) now. :slight_smile:
No idea why it had stopped, nor why it had started working - but so far it works. :slight_smile:

I’m thinking now that this may have been related to this: https://support.cpanel.net/hc/en-us/articles/360048670574-Root-CA-Certificate-Expiration

I’m running a loop now to unblock their IP ranges. Let the spam begin :joy: