emails never arrives

I tried to change my e-mail registered at the forum of website, but the confirmation e-mail never arrives. I change back to my e-mail address at Gsuite, and the confirmation e-mail arrives instantly. I checked the e-mail that arrived at the Gsuite address, and it seems that it has SPF errors.

Delivered-To: <redacted>
Received: by 2002:a05:6512:224c:0:0:0:0 with SMTP id i12csp1256283lfu;
        Sat, 8 May 2021 05:32:06 -0700 (PDT)
X-Google-Smtp-Source: ABdhPJwaO0VJJBZkoSMIXZJgs/ERDmQ0158g3cTV9ZqqWuEArkwhHfYFQ9H/adyQPvcx4PTGc8kH
X-Received: by 2002:a2e:8715:: with SMTP id m21mr11933428lji.319.1620477126402;
        Sat, 08 May 2021 05:32:06 -0700 (PDT)
ARC-Seal: i=1; a=rsa-sha256; t=1620477126; cv=none;; s=arc-20160816;
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed;; s=arc-20160816;
ARC-Authentication-Results: i=1;;
       spf=temperror ( error in processing during lookup of DNS error)
Return-Path: <>
Received: from ([])
        by with ESMTPS id k12si8053828lfv.368.2021.
        for <redacted>
        (version=TLS1_3 cipher=TLS_AES_256_GCM_SHA384 bits=256/256);
        Sat, 08 May 2021 05:32:05 -0700 (PDT)
Received-SPF: temperror ( error in processing during lookup of DNS error) client-ip=;
       spf=temperror ( error in processing during lookup of DNS error)
Received: from ( []) by (8.16.1/8.15.2) with ESMTP id 148CW4ZO395507 for <redacted>; Sat, 8 May 2021 14:32:04 +0200
Date: Sat, 08 May 2021 12:32:04 +0000
To: <redacted>
From: "Doom9's Forum" <>
Auto-Submitted: auto-generated
Message-ID: <>
MIME-Version: 1.0
Content-Type: text/plain; charset="ISO-8859-1"
Content-Transfer-Encoding: 8bit
X-Priority: 3
X-Mailer: vBulletin Mail via PHP
Subject: Action Required to Verify Email Change for Doom9's Forum

I do indeed see the rejections on the Echo server. The emails were sent to and not @ a customer domain. I can’t imagine why they’d send to an address like that unless it was given to them, but surely you wouldn’t input that?

Of course, I use the e-mail in my profile. I have no idea why that happens.

Ok, I got it already, I just removed the CNAME record that links the e-mail domain to and everything works now. Damn, I am not supposed to do that?

There are different conditions where a CNAME record to the server makes sense and when it doesn’t. For custom mail and webmail subdomains it makes sense. Example: Custom Webmail/POP/IMAP/SMTP Domain – MXroute (

But is our domain, our server that you point yours to so that our server handles email for your domain. So for example, my domain is, and it is hosted on (just like echo, different physical server). People don’t email me at, they email me at, because’s MX records point to, which means that handles the email for